Notice: Undefined variable: keyword in /home/domains2/public_html/william-hurt.com/inc/meta.php on line 18
Overheating vacuum? My Hoover U5134-980 has worked fine for the past year. Lately, however, it has smelled like it is o


Notice: Undefined variable: position6 in /home/domains2/public_html/william-hurt.com/show.php on line 114

Guide :Vacuums : U5144900 / U5146900 / U5147900 Tempo Bagged Upright Vacuum

Overheating vacuum? My Hoover U5134-980 has worked fine for the past year. Lately, however, it has smelled like it is overheating to the point where I can no longer vacuum because of the smell. I opened it up and the belt had melted and become disfigured because the metal part that it attaches to became so hot. I opened it up further and found a large amount of lint on the filter near the light bulb and removed that. I also replaced the belt. Neither of these things has helped. It seems to work okay, but the smell is really awful and seems dangerous. Any ideas?

Posted by Lauren Terhaar on Apr 14, 2007

Research, Knowledge and Information :



Notice: Undefined variable: position4 in /home/domains2/public_html/william-hurt.com/show.php on line 230

Loading ...

Tips for a great answer:

- Provide details, support with references or personal experience .
- If you need clarification, ask it in the comment box .
- It's 100% free, no registration required.

Notice: Undefined variable: position5 in /home/domains2/public_html/william-hurt.com/show.php on line 283
  • Start your question with What, Why, How, When, etc. and end with a "?"
  • Be clear and specific
  • Use proper spelling and grammar
all rights reserved to the respective owners || www.william-hurt.com || Terms of Use || Contact || Privacy Policy
Load time: 0.0190 seconds